三层架构:MST+HSRP+ospf

高冗余度的三层架构(CCIE)

接入与汇聚层使用MST+HSRP核心层ospf再用HSRP做下一跳冗余,全网可达:

  • 核心汇聚层设备双线链接,采用链路聚合
  • 汇聚层使用MST生成树,划分两个vlan,两个核心交换机分别做根
  • 热备份网关冗余技术,使用HSRP分别为两个vlan做虚网关
  • 配置简单的vtp
  • 使用生成树的特性做了简单的稳定性防护:bpduguard、udld

核心层起动态路由协议和使用HSRP的两种情况分别讨论
第一种情况:在核心层使用ospf动态协议
第二种情况:核心层使用HSRP做下一跳冗余和上行链路追踪,在双线冗余情况下双线链接都断裂才切换;保证来回路径一致,针对回程路由做了相应配置,核心层NAT出去访问外网


拓扑图

实验拓扑:
以下为实验拓扑图
使用的设备:
实验使用的设备型号
实验要求:
1、汇聚层配置简单的VTP,C设备与D设备接入层分别划分为vlan2,vlan3
2、A、B之间使用链路聚合
3、A、B、C、D间使用MST生成树,分别建立两个实例使得A作为vlan2的主根,B为备份,B作为vlan3的主根,A备份(负载分流结构),生成两棵树
4、A、B上起SVI虚接口,做HSRP,两个vlan分别对应两个虚网关
5、(5.1)、核心层使用ospf的情况,HSRP开上行链路追踪,此种情况忽略3660_R和3660_R1的存在,在R2上起个环回看做外网,R2,A,B之间起ospf,要求全网可达,两台PC可以访问外网也可以互相访问
(5.2)、在核心层使用HSRP做下一跳冗余的情况下,在R1,R2间做一个虚网关,A、B开启上行链路追踪:要求当两条链路到断开后才切换至B;要求数据流量来回路径一致;R上起环回做外网,在R1,R2上做NAT;
6、测试在某些链路故障的情况下数据流量路径的切换,以及各台设备在其中担任的角色的切换,生成树的变化
**


配置信息与详解

1、首先,把trunk起好
switchport trunk encapsulation dot1q
switchport mode trunk
2、用A做vtp的server同步B、C、D,在A上创建vlan2,vlan3
vtp domain ccie
vtp mode server
vlan 2,3
3、将C、D的e0/2接口分别划入vlan2 ,vlan 3
4. A和B中间的链路做聚合
inter range e0/2-3
channel-group 1 mode desirable
5、在A,B、C、D上配置生成树,A为实例1的root,B为实例2的
这里写图片描述
这里写图片描述
6、查看生成树情况如下
A上查看:
这里写图片描述
B上查看:
这里写图片描述
此时形成了负载分流结构
7、分别给vlan2,vlan3起SVI虚接口,并使用HSRP做虚网关
(此处配置254为真实网关,253为备份网关。252为虚拟网关)
B上:
interface Vlan2
ip address 10.1.2.253 255.255.255.0
standby 0 authentication md5 key-string cisco
standby 1 ip 10.1.2.252
!
interface Vlan3
ip address 10.1.3.254 255.255.255.0
standby 2 ip 10.1.3.252
standby 2 priority 120
standby 2 preempt
standby 2 authentication md5 key-string cisco
standby 2 track 1 decrement 25
!
A上:
interface Vlan2
ip address 10.1.2.254 255.255.255.0
standby 1 ip 10.1.2.252
standby 1 priority 120
standby 1 preempt
standby 1 authentication md5 key-string cisco
standby 1 track 1 decrement 25
!
interface Vlan3
ip address 10.1.3.253 255.255.255.0
standby 0 authentication md5 key-string cisco
standby 2 ip 10.1.3.252
这里写图片描述


接下来先配置第一种情况,如下图只看已经开机的部分
这里写图片描述
8、R、A、B之间起ospf
在A、B上新创建一个vlan10,配置ip为23.1.1.0 /24位网段,也加入ospf
R上起一个环回假装是外网
R上:router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 12.1.1.0 0.0.0.255 area 0
network 13.1.1.0 0.0.0.255 area 0
A上:router ospf 1
router-id 2.2.2.2
network 10.1.0.0 0.0.255.255 area 0
network 12.1.1.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
B上:router ospf 1
router-id 3.3.3.3
network 10.1.0.0 0.0.255.255 area 0
network 13.1.1.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
建邻关系如下:
这里写图片描述
这里写图片描述
这里写图片描述

可以看到这里的邻居关系多余,A和B上互相建邻的有三条,是vlan2 和vlan3搞得事情,可以把这两个svi做成被动接口来解决
A(config)#router ospf 1
A(config-router)#passive-interface vlan 2
A(config-router)#passive-interface vlan 3
B上同A的配置

现在邻居关系就很ok了
这里写图片描述
这里写图片描述

至此整个三层架构就初步完成了,先来测试一下
PC1:
VPCS> ip 10.1.2.251 255.255.255.0 10.1.2.252
Checking for duplicate address…
PC1 : 10.1.2.251 255.255.255.0 gateway 10.1.2.252
这里写图片描述
PC2:
VPCS> ip 10.1.2.251 255.255.255.0 10.1.2.252
Checking for duplicate address…
PC1 : 10.1.2.251 255.255.255.0 gateway 10.1.2.252
这里写图片描述
这样两个虚接口就通了,做网关很棒棒

我们在R2 上起了一个环回6.6.6.6,来来来(激动地搓手手)
PC1:
这里写图片描述
VPCS> trace 6.6.6.6 -P 1
trace to 6.6.6.6, 8 hops max (ICMP), press Ctrl+C to stop
1 10.1.2.254 5.060 ms 0.949 ms 2.099 ms
2 6.6.6.6 97.775 ms 256.046 ms 281.141 ms
PC2:
这里写图片描述
VPCS> trace 6.6.6.6 -P 1
trace to 6.6.6.6, 8 hops max (ICMP), press Ctrl+C to stop
1 10.1.3.254 1.072 ms 0.706 ms 0.738 ms
2 6.6.6.6 16.529 ms 7.841 ms 8.176 ms
呜啦!~好啦!
不过有个小问题,看这里
R2#traceroute 10.1.2.251

Type escape sequence to abort.
Tracing the route to 10.1.2.251

1 13.1.1.3 12 msec
12.1.1.2 8 msec
13.1.1.3 12 msec
2 10.1.2.251 16 msec 40 msec 56 msec
ping回去的话路径和来的时候不一致,负载均衡了一下就很烦,关于这个问题下篇再来讨论,第二种情况中去解决。这里先来测试一下冗余管不管用。
A(config)#inter e1/0
A(config-if)#shu
关掉A的口再来看,网关变了没

VPCS> trace 6.6.6.6 -P 1
trace to 6.6.6.6, 8 hops max (ICMP), press Ctrl+C to stop
1 10.1.2.253 25.937 ms 12.903 ms 11.296 ms
2 6.6.6.6 22.562 ms 11.056 ms 18.304 ms
好的网关切了,再no suhtdown回来
A(config)#inter e1/0
A(config-if)#no shu
VPCS> trace 6.6.6.6 -P 1
trace to 6.6.6.6, 8 hops max (ICMP), press Ctrl+C to stop
1 10.1.2.254 65.008 ms 43.735 ms *
2 6.6.6.6 149.650 ms 282.265 ms 82.395 ms
等待一会之后又回来了,很成功!
再来看看生成树
直接把A关机,来看
这里写图片描述
这里写图片描述
可以看到B把mst的根抢过来了,那么这时候vlan2下的pc还能通吗?
VPCS> trace 6.6.6.6 -P 1
trace to 6.6.6.6, 8 hops max (ICMP), press Ctrl+C to stop
1 10.1.2.253 4.509 ms 1.134 ms 0.952 ms
2 6.6.6.6 12.248 ms 9.495 ms 9.678 ms
* Perfect!*
那么,本篇到此为止

本文链接:三层架构:MST+HSRP+ospf

本站文章转载请注明来源:Linux网.com